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Installation 
Installation of the RSD2013 software is simple. Unpack the compressed zip file to a location of your choice. You can easily start off using 

the software by running the RSD2013_GUI.exe which opens the graphical user interface (GUI). The RSD2013 software only runs on a 

Windows platform. 

Files and directories 

RSD2013_GUI.exe 

This executable starts the graphical user interface (GUI) of the RSD2013 software. The GUI allows to create the necessary input files and to 
start up one or more RSD simulations. 

RSD2013.exe 
This executable can only be started from the command line supplied with the main input file. It starts an individual RSD simulation specified 

by this main input file which may be generated with the GUI or manually. Renaming RSD2013.exe will make running simulations through 

the GUI impossible. 
Changelog.txt 

This document summarizes the new features and bug fixes in each release of RSD2013. 

README.txt 

Short documentation to quick start the use of RSD2013 and the used formatting conventions of the simulation output. 

Disclaimer.txt 

This document contains the DISCLAIMER OF WARRANTIES AND LIMITATION OF LIABILITY. 

icons 

This directory contains the icons and figures used in the GUI. This directory should be left intact. 

templates 

This directory contains headings which are attached to the generated input files. This directory should be left intact. 



simtra_v2.2 (optional) 

This directory contains the Monte Carlo simulation program SiMTra which may be used to produce (re)deposition profile files of the 
sputtered material on the substrate (and target) surfaces. 

INPUT (optional) 

This directory contains example (main) input files for RSD simulations. It can optionally been used to store your own input files. 

OUTPUT (optional) 

In this directory, the output files from the example RSD simulations be saved. It can optionally been used to save your own simulation 
output. 

Overview 
The RSD2013 software is developed to simulate the reactive sputter process of a constant or pulsed DC magnetron. Process operation 

curves as function of a single Varied operation parameter are reproduced where the focus is on a possible hysteresis in the 

observables as function of this Varied operation parameter. Two models are provided: the “original” Berg model or the RSD2013 

model. The mathematical formulation of both models can be found in the thesis “Modeling the reactive magnetron sputtering process”www 
and in the article “ A time-dependent model for reactive sputter deposition”www. 

 
Their can be some confusion in terminology but context should make things clear: 

- RSD simulation = simulation with the Berg model or the RSD2013 model 

- RSD2013 = either the simulation software as a whole or the specific RSD2013 model 

- RSD input files = input files for a RSD simulation 

The following variables are resolved, depending on the used model and the chosen options: 

Variable Units Description  

pr Pa pressure reactive gas in the system  

θm - fraction non-reacted metal sites at target surface   

θm,ss - fraction non-reacted metal sites at target surface/subsurface interface [RSD only] 

https://www.researchgate.net/publication/294444833_Modeling_the_reactive_magnetron_sputtering_process
http://dx.doi.org/10.1088/0022-3727/47/23/235302


Variable Units Description  

θc - fraction chemisorbed metal sites at target surface  

θr - fraction reacted metal sites at target surface [RSD only] 

θs - fraction reacted metal sites at substrate surface  

nM #M cm-3 concentration non-reacted metal M in target subsurface [RSD only] 

nR #R cm-3 concentration non-reacted implanted reactive gas atoms R in target subsurface [RSD only] 

vs cm s-1 surface speed of target  

ve cm s-1 erosion speed of target  

de cm erosion depth of target  

εt cm-2 redeposition fraction surface density [RSD only] 

εs cm-2 deposition fraction surface density  

Qr sccm flow of molecular reactive gas introduced into the vacuum chamber  

Qt sccm flow of molecular reactive gas initially getterd by the target  

Qs sccm flow of molecular reactive gas gettered by the substrates  

Qp sccm flow of molecular reactive gas gettered by the vacuum pump  

S Ls-1 pumping speed by the vacuum pump  

I A discharge current  

Iion A discharge ion current  

V V discharge voltage  

These variables are resolved by the models on the condition that several material and operation parameters are specified as input. These 
input parameters are clarified throughout the following sections. 



Quick start 
To run a first simulation, you just double click the GUI executable RSD2013_GUI.exe. By default a complete input is specified in the window 

tabs Method, Chamber, Target, Substrate and Output. 



 



Default input.  

To run this default simulation, save first the simulation input. By choosing File > Save as ... in the menu bar or , a window pops up 

to specify a saving location and a name for the main input file. Choose as location the INPUT directory under the RSD program folder, and 

as name, for example, my_first_RSD_simulation.in. Press the Save button. Two input files will be created, namely 

my_first_RSD_simulation.in and my_first_RSD_simulation_OutputSpecs.in. The first file is the main input file, while the second 

file is the results specification file. These specifications are defined in the window tab Output under Results. 



 
Saving input main file.  

The name of the main input file is now listed in the left side window and selected if it is blue highlighted. 

 
On the first saving of the input file or using File > Save as ..., the Select the output directory: and the Prefix for output 

files: will be automaticly (re)assigned based on the file name. A new output directory with the file name as name is created, one level up 



in the directory tree that was specified in Select the output directory:. We changed this output directory to 

.\OUTPUT\my_first_RSD_simulation which will save the output to the relative directory within the program directory. 



 



List of input files.  

To run the simulation of this selected input file, choose in the menu bar Simulation > Run selected or . If everything goes well, a 

command prompt window pops up, showing the progress of the simulation which closes itself on the end of the simulation. 

 
Running simulation.  



To look at the simulation results you have to know where the output files are saved. To check this, go to the window tab Output. In the field 

Select the output directory: next to the button Choose, the location where the output files are saved is given. The field Prefix 

for output files: underneath gives the prefix string which every output file will start with. By default this string is the name of the main 

input file. When browsing to the output file location with Windows explorer, you will see two output files recognizable by the extension .out 

and two log files recognizable by the extension .log. The file ending with _summary.out is always generated. This file is updated during 

the simulation run and shows the progress of the simulation as given by the command prompt window. At the end of the simulation it gives 

the elapsed time for this simulation run and its ending time. The other file ending with _hyst_steady.out contains the simulation results. 

As this is a steady state simulation, the reactive gas pressure (second column) is increased up to the value 0.2 as specified in field 

Maximum reactive pressure (Pa) in the window tab Method, and subsequently decreased. The total number of pressure values that 

are calculated, by default 300, is specified by the field Number of points under the same window tab Method. The columns of this output 

file with the steady state solution gives the results of the following variables: 
1. Q_r : flow of reactive gas introduced in the vacuum chamber 
2. p_r : partial pressure of reactive gas 
3. theta_s : spatial averaged compound fraction on substrate surface 
4. theta_m : spatial averaged metal fraction on target surface 
5. theta_c : spatial averaged chemisorbed fraction on target surface 
6. theta_r : spatial averaged compound fraction on target surface 
7. theta_m,ss : spatial averaged metal fraction at the target surface/subsurface interface 
8. n_R/n0 : relative concentration of non-reacted implanted reactive gas atoms at the target surface/subsurface interface 
9. Q_p : reactive gas flow pumped away by the vacuum pump 
10. Q_s : reactive gas flow consumed by compound formation on the substrate 
11. Q_t : reactive gas flow consumed (> 0) or released (< 0) by the target 
12. V : discharge voltage 
13. I : discharge current 
14. I_ion : ion current to the target 
15. S : pumping speed of the vacuum pump 



 
Example of output file.  

Graphical User Interface (GUI) 



The graphical user interface (GUI) is designed to create input files for a RSD simulation in a user-friendly way. These input files can also be 
manually composed. Single or multiple simulation(s) can also be executed from within the GUI. The GUI can be accessed by the executable 

RSD2013_GUI.exe. It most important task is to compose the input files for the simulation executable RSD2013.exe. In fact, when starting a 

simulation from within the GUI, it opens a Windows Command Prompt and runs the RSD2013.exe executable with as single argument the 

absolute or relative path of the main input file. 

Concept 

The concept of the GUI is doing the following tasks: 

 create new input files 
 load existing input files 
 edit input files 
 run single or multiple simulations 
 setup a series of simulations (see Scan) 

The philosophy of the GUI is as follows. The input of a single simulation is defined in the window tabs, namely Method, Chamber, Target, 

Substrate and Output. The window at the left of the window tabs is the simulation list window which lists the different simulations. 

Existing input files can be loaded or new input files can be created. The name within the list is the name of the main input file of a particular 
simulation. After selecting one or more items in the list, the user can let sequentially run these simulations. 

Menu 

The menu bar is located at the top of the GUI window. Through this menu the user can 

 Open or load existing simulations (see File) 
 Create new simulations (see File) 
 Save changes to simulations (see File) 
 Start simulations (see Simulation) 
 Abort running simulations (see Simulation) 

The action of every menu item and icon is explained below. 

File 

Open  



To open or load an existing main input file for editing. Made changes will be saved to this opened main input file and its referenced 
additional input files. 

Hotkey: Ctrl+O 

Open as copy 

To open or load a copy of an existing main input file for editing. A new name and saving location is asked for the copy. Changes are saved 
to the created copy. Only the main input file is copied which contains links to the original additional input files. Made changes to these 
additional input files will as such effect the original. 

New  

To internally open a new input simulation. It resets the fields in the window tabs to their default values. The input is unsaved (and unlisted) 

until the Save or Save as ... is used. 

Hotkey: Ctrl+N 

Save  

To save the changes made in the window tabs to the main and additional input files. The made changes in the window tabs are saved to the 

current selected (blue highlighted) item in the window list. If no main input file is assigned yet, this action corresponds to a Save as ... 

action. 

Selecting an other item in the simulation list window, which is loaded into the window tabs, initiates this Save action for the previous 

selected item. 

Hotkey: Ctrl+S 

Save as …  

To save and specify a new main input file for the current input of the window tabs. A new main input file is generated together with the 
additional input files. The main input file is added to the simulation list. 

Exit 



To exit and close the GUI window. It will not terminate any running simulation. 

Simulation 

Run selected  

To run the selected (blue highlighted) simulations of the simulation list in sequence. 

Hotkey: Ctrl+R 

Run all 

To execute all the simulations of the simulation list in sequence, independent if they are selected or not. 

Auto prefix 

When checked, it will replace the value of the field Prefix for output files: in the window tab Output of all items in the window list 

by a three digit number in the same order as they are listed. Numbering starts from 000. 

 
When two or more items in the simulation list have the same prefix for the output files, a warning will appear. In this case, simulation results 
will overwrite each other. 

Kill current run  

To kill or abort all running RSD simulations. In fact, it will kill all running RSD2013.exe processes on your platform. 

Hotkey: Ctrl+K 

Help 

Manual  

To open the this documentation in a browser. 



About  

To show information about the RSD2013 software and to whom it acknowledges. 

Tabs 

The window tabs graphically represent the information contained in the input files of a selected (blue highlighted) simulation in the 
simulation list. Editing the fields of these tabs changes the simulation input and options. 

All simulation options are visual within the window tabs. Unused or irrelevant options or fields are grayed out and made inaccessible. They 

become (in)accessible depending on which simulation choices you make. For example, when choosing the Steady state method in the 

window tab Method as solution method, then the fields connected to the Time evolution method are irrelevant and as such grayed out. 

 
Only a limited control on the input values is performed. Faulty input may crash the software at any moment and is up to the users 
responsibility. 

Method 

The window tab Method basically specifies which model(s) should be used, which kind of solution method is applied,how the process curve 

is operated and optional where to find the SiMTra simulation software. 



 



Method window tab.  

Model 

 RSD2013 

This model is an extension of the Berg model with as most important extra feature the subsurface implantation of reactive gas ions/atoms 
and a 2nd order reaction mechanism in the subsurface forming the compound. A chemisorption mechanism governs the reaction on the 
surface. Redeposition of sputtered material back on the target can be taken into account. 

 Berg 

This model is a monolayer surface model which only considers a chemisorption mechanism on the target (and substrate) surfaces. No 
redeposition can be considered. 

Operation 

The process curve with possible hysteresis behavior is simulated as function of a Varied operation parameter(s) while other 

operation parameters are kept fixed and specified under Chamber>Operation conditions. The plasma discharge is characterized by 

the operation discharge parameters Discharge voltage, Discharge current and Discharge power where one discharge parameter 

can be fixed or all. 

 Varied operation parameter(s) 

The operation parameter(s) that will vary along the process curve/hysteresis. Multiple operation parameters can only be varied in the Time 

evolution method. 

Choices are 
o reactive flow (sccm) 

o pump speed (Ls-1) [RSD only] 

o voltage (V) [RSD only] 

o current (A)[RSD only] 

 Limited discharge parameter 

The discharge parameter(s) that is (are) kept fixed along the process curve/hysteresis, specified in Chamber>Operation conditions. 

o voltage, current or power [RSD only] 

The discharge parameter that has a fixed value. The other discharge parameters are determined by the IV-characteristics. 

o all : 

All discharge parameters have a fixed value. 



o N/A [RSD only] 

All discharge parameters are determined by the IV-characteristics. 

Only if all is chosen, their is no need for specifying Chamber>IV-characteristics. 

If the Berg model is chosen, only the option Varied operation parameter>reactive flow with Limited discharge 

parameter>all is currently possible. 

Solution method 

As solution method, two options are available the Steady state method and the Time evolution method. 

 Steady state method 

The chosen Model will be solved as a steady state model (with time derivatives set to zero) to simulate the process curve/hysteresis. It 

simulates the entire process curve/hysteresis including the potential unstable regions. The independent variable pr (or V) is first stepwise 

increased (or decreased) over the Solution range and subsequently decreased (or increased).  

o Solution range  

 Number of points : 

The total number of simulated points along the process curve/hysteresis. Each value of the independent variable is simulated twice. Once 
for the increasing and once for the decreasing direction. 

 Minimum reactive pressure (Pa) or Minimum voltage (V) : 

Lower bound for the independent variable based on the Varied operation parameter choice. 

 Maximum reactive pressure (Pa) or Maximum voltage (V) : 

Upper bound for the independent variable based on the Varied operation parameter choice. 

 Log scale : 

Distributes the simulation points logarithmic between lower and upper bound (default: linearly). 

If a range of discharge voltage is requested, the steady state solver will translate this to a conform reactive pressure range to use as 
independent variable and solve the model. In this way, the specified discharge voltage range will not coincidence with the output range. 

 Time evolution method 

The chosen Model will be solved as a time dependent model. The Varied operation parameter(s) is (are) stepwise in- or decreased 

with an optional periodic pulsing accordingly the specifications in the Step file.  

o Step file 

The created step file is an additional input file and defines the predefined evolution of the Varied operation parameter(s).  

 New step file or Change step file : 

Opens the window Creating step file where a new or existing step file can be modified. 



 Loading step file : 

Allows to choose the path of an existing step file which will be represented in the text field. Direct editing of this text field is also possible. 

 Move to next step if steady state is reached : 

Initiates the next Varied operation parameter(s) value only when the process reaches a steady state condition, even a periodic 

steady state in case of Pulsing of at least one of the Varied operation parameter(s). If Force to next flow if maximum time 

is reached is enabled, it initiates the next Varied operation parameter(s) when steady state is reached OR when the maximum 

time for this set value of the Varied operation parameter(s) is reached. 

 Move to next step if maximum time is reached : 

Initiates the next Varied operation parameter(s) value only when the maximum time for the current Varied operation 

parameter(s) value is reached. 

o Integration  

 Time step (s) : 

It defines the integration step Δt of the explicit 4th order Runge-Kutta integrator which numerically solves the ordinary differential equations of 
the variables θm, θc, θr, θs and p;r, and optional I and V. 

Creating step file 



 
Window Creating step file  

A step file consist of a list numerical text lines which define a stepwise in/decrease of each of the specified Varied operation 

parameter(s). Each line consist out of four entries: 

 Start : 

The start value of the listed Varied operation parameter(s) as a ‘\’ separated string. 



 End : 

The end value of the listed Varied operation parameter(s) as a ‘\’ separated string. 

 Step : 

The value with which the Start value of the first listed Varied operation parameter(s) is stepwise in/decreased until it reaches the 

End value. The other Varied operation parameter(s) their Step is defined by the stepping of this first listed Varied operation 

parameter(s). 

 Maximum time (s) : 

The maximum time each stepped value of the Varied operation parameter(s) is set during the simulation. 

The Insert button adds a line to the step file. The already defined lines are shown as a list in the upper window. 

By clicking on a line in this list, the line is selected (blue highlighted). By pressing Delete, the line is removed. 

By double clicking, the line is selected and loaded in the editing fields. The Varied operation parameter(s) that needs to be changed, 

is selectable next to Operation parameter:. Only the Step of the first listed operation parameter can be edited as the other step are 

defined by this Step. After making changes to the line, you can press the Save change button to save the changes to the original line. 

 Pulsing 

Optional one or more of the Varied operation parameter(s) can have a pulse character as  

o NA: 

No pulsing of the selected Operation parameter. 

o block: 

The selected Operation parameter is block pulsed, shaped by the parameters below and given in the figure. 

o sinus: 

The selected Operation parameter has a sinusoidal form, shaped by the parameters below and given in the figure.  

 Period (s) : 

The total time of a single period 

 Duty cycle : 

Fraction (0 to 1) of the period where the Varied operation parameter(s) reaches its scaled Maximum value. 

 Off-pulse minimum : 

Relative scaling of the Varied operation parameter(s) during the off-time or minimum of the pulse which precedes the on-time or 

maximum of the pulse. 

 On-pulse maximum : 

Relative scaling of the Varied operation parameter(s) during the on-time or maximum of the pulse which comes after the off-time or 

minimum of the pulse. 



 
Definition of block pulsing of operation parameters.  

 
Definition of sinusoidal pulsing of operation parameters.  

Pressing the Ok button save the change to loaded step file or pops up a window to specify a saving location if no step file is loaded yet. A 

default name is suggested. It is a concatenation of the string stepFile with the name of the main input file. 

Save as ... allows to save the stepping as a new step file and replace the original loaded step file. 

SiMTra 



If SiMTra simulated deposition profiles should be included, the SiMTra home directory has to be specified. This version of RSD is 
compatible with SiMTra v2.2 which accompanies the RSD2013 software. 

 Use SiMTra deposition simulations 

If checked, SiMTra simulated deposition profiles can be simulated and/or included. The SiMTra home directory containing the executables 

simtra_gui.exe and simtra_cmd.exe should be specified with its absolute or relative path in the text field.  

o Synchronise RSD with SiMTra input 

If checked, the parameters defined by the SiMTra input file will be transferred to the RSD software and the relevant parameter fields will be 
made non-editable. The following simulation parameters will be synchronized with SiMTra: 

 Volume (cm3) 

It will import the volume of the chamber object defined in SiMTra as it is completely empty. 

 Ar pressure (Pa) 

It will import the defined gas pressure. 

 Temperature (K) 

It will import the defined gas temperature. 

 Target Area (cm2) 

It will import the area of the surface object that is assigned to sputter. 

 Substrate Area (cm2) 

It will import the total sum of all defined surface objects where deposition is recorded. 
o Run SiMTra within RSD simulation 

If checked, the SiMTra simulation as specified by the SiMTra input file in the window tab Target>Metal particle M>Simtra for the 

deposition profile of the sputtered metal will (re)started before the effective RSD simulation is performed. 
If not checked, the SiMTra simulation should have been executed before as the output is expected to reside on the location given by the 
SiMTra input file. 

o Enable movement 

A periodic movement should be specified in the SiMTra simulation.  
 full period 

The end of a period is followed by its start. 
 half period 

At the end of a period the movement reverse in direction towards its start where it reverse again. 

Chamber 

The window tab Chamber specifies the parameters connected to the gases in the chamber, the fixed operation conditions and the IV-

characteristics for the different target states. 



 



Chamber tab window.  

Operation conditions 

The discharge operation parameters and chamber conditions. 

 Discharge power (W) [RSD only] 

A fixed electrical power P for the discharge. To be specified if Limited discharge parameter is power. 

 Discharge current (A) 

A fixed electrical current I for the discharge. To be specified if Limited discharge parameter is current or all. 

 Discharge voltage (V) 

A fixed electrical voltage V for the discharge. To be specified if Limited discharge parameter is voltage or all. 

 Reactive flow (sccm) [RSD only] 

A fixed reactive flow Qr introduced into the vacuum chamber. To be specified if Varied operation parameter(s) is pump, current or 

voltage. 

 Pump speed (L s-1) 

A fixed volumetric pumping speed S of the reactive gas out of the vacuum chamber. To be specified if Varied operation parameter(s) 

is reactive flow, current or voltage. 

The system pumping speed can be determined as the slope of the steady state Qr-pr relation when the discharge is off. For correctness, 
the fixed Ar gas pressure should be established, as the pumping speed may depend on the gas mixture. 

 Volume (cm3) 

A fixed volume V of the vacuum chamber which occupies the gases. Only relevant for the Time evolution method. 

The volume of the vacuum chamber can be estimated based on the time evolution of the gas pressure pr when the gas flow Qr is 
changed. Knowledge of the pumping speed and gas temperature is then required. 

Gas 

Parameters specifying the used reactive gas, the global gas temperature and Ar pressure. 

 Ar pressure (Pa) [RSD only] 

The fixed and constant pressure pAr of the inert argon gas in the vacuum chamber. 

 Temperature (K) 

The fixed and constant temperature T of the reactive and inert Ar gas. 



 Molar mass reactive gas (g mol-1) 

Specifies the used diatomic molecular reactive gas by its molar mass. 

IV-characteristics [RSD only] 

If the Limited discharge parameter is not set to all, three current-voltage characteristics (IV-characteristics) should be specified for 

the target in a complete Metallic, Compound or Chemisorbed state at the specified Ar pressure (Pa). These IV-characteristic are 

highly system dependent (magnetic field configuration, gas pressure, inert gas type). Each IV-characteristic has the form: 

 
 

with the parameters k, V0 and n depending on the Target state. 

IV-characteristics for magnetrons are often well fitted by the Westwood relation www (n=2). 

While IV-characteristics for a Metallic and a Compound target state can often been measured, this is not the case for a Chemisorbed 

target state. This chemisorbed IV-characteristic may be a fitting element or equally set like the metallic or compound IV-characteristic. 

Target 

The window tab Target specifies the properties and interaction mechanisms of the particles on the target surface and subsurface. There 

are the sputtered particles (M and MRz), the deposited particles (M and R) and the implanted particles (R2
+). It also specifies the geometry of 

the sputtered target and optional if redeposition of sputtered material back on the target should be considered. 

https://doi.org/10.1063/1.332006


 



Target tab window tab (part 1).  

Metal particle M 

 Molar mass (g mol-1) 

Specifies the sputtered metal element M by its molar mass. 

 Mass density (g cm-3) 

Specifies the sputtered metal element M by its mass density. 

A metal particle density n0 is calculated from the Mass density and the Molar mass. This density n0 is the metal density in the target, 

independent if the metal is in a bounded or unbounded state with reactive atoms. 

 Sputter yield Y_m (#M ion-1) 

The sputter yield of metal particles M per incoming ion if the metal is not bounded with reacitve atoms (metallic state). This can optional be 
specified as a linear function of the discharge voltage. No distinction is made between inert or reactive incoming ions. 

Metal sputter yields can be measured by a weighting or volume method but can also be simulated with Monte Carlo codes like SRIM www. 

 Secondary electron yield (#e ion-1) 

The ion-induced secondary electron emission yield for non-reacted metal. If different from zero, the discharge current is considered to have 
an ion and an electron contribution. Otherwise discharge and ion current are assumed equal. 

Secondary electron yields of metals can be retrieved from Depla et al. www. 

 SiMTra 

If SiMTra deposition profiles of the sputtered metal are considered, the SiMTra input file should be specified or a new SiMTra simulation has 
to be set up. 

A loaded SiMTra input file will represent the target surface in Target> Geometry> Redeposition profile> SiMTra configuration> 

Object/Surface and the substrate surfaces in Substrate> Geometry> Deposition profile> SiMTra configuration> 

Object/Surface. 

To load or set up such a SiMTra input file, one can use 

o New input or Change input 

If the adjacent text field does not contain an absolute or relative path to a valid SiMTra input file, the New input will start up the SiMTra 

GUI to compose a new SiMTra simulation configuration. After saving this SiMTra configuration and closing the SiMTra GUI, the last saved 
SiMTra input file will be shown in the adjacent text field. 

If the adjacent text field does contain an absolute or relative path to a valid SiMTra input file, the Change input will start up the SiMTra 

GUI to edit the existing SiMTra simulation configuration. 
When a 

o Load input 

Browse for an existing SiMTra input file which will be shown in the adjacent text field. 

http://www.srim.org/
https://doi.org/10.1016/j.surfcoat.2005.02.166


o Output directory 

Non editable text field which shows the output directory for the SiMTra simulation. This output directory is only editable in the SiMTra GUI or 
the SiMTra input file. 

If the text field of Output directory is empty, their is no valid SiMTra input file specified. 

Reacted particle particle MR_z 

Two types of reacted metal particles are considered. Compound particles are formed in the subsurface by reaction of implanted reactive gas 
ions and the metal atoms which come to the surface by sputter erosion. Chemisorbed particles are formed on the surface due to the 
chemisorption of the molecular reactive gas on non-reacted metal atoms. Reaction and particle specific parameters should be specified 
here. 

 Stoichiometry z in MR_z 

The stoichiometric factor z as the number of reactive gas atoms R bounded on a metal atom M. This stoichiometric factor is the same for all 
reacted metal particles as well on the target as on the substrate. 

In principle the model can only handle compounds with a single oxidation state like Al2O3, Y2O3 and MgO. 

 Compound particle MR_z [RSD only] 

o Sputter yield Y_r (#M ion-1) 

The sputter yield of compound particles MRz per incoming ion if the metal is bounded with reactive atoms (compound state). This can 
optional be specified as a linear function of the discharge voltage. No distinction is made between an incoming inert or reactive ions. 

By definition the compound sputters congruently (=maintaining the existing stoichiometry) but are sputtered as atoms. 

Effective compound sputter yields can be measured by a weighting or volume method. Simulation by Monte Carlo codes like SRIM www 
require suitable surface binding energies of the components and reproduce ‘pure’ sputter yield without the effect of dilution by the implanted 
gas concentration. Gas consumption measurements as proposed by Schelfhout et al. www give good estimates for these effective sputter 
yield. 

o Secondary electron yield (#e ion-1) 

The ion-induced secondary electron emission yield for compound. If different from zero, the discharge current is considered to have an ion 
and an electron contribution. Otherwise discharge and ion current are assumed equal. 

Secondary electron yields of compounds can be retrieved from Depla et al. www. 

o Bulk reaction rate (cm3s-1#R-1) The 2nd order reaction rate coefficient for the formation of compound particles MRz in the subsurface 

from implanted reactive gas ions and non-reacted metal atoms. 

The reaction rate is in close relationship with the compound sputter yield, and both parameters dominate the position of the second 
critical point. It may be considered as a fit parameter. More info www, www. 

http://www.srim.org/
https://doi.org/10.1088/1361-6463/aab321
https://doi.org/10.1016/j.tsf.2008.11.108
https://doi.org/10.1016/j.surfcoat.2012.03.019
https://doi.org/10.1016/j.surfcoat.2015.07.064


o Knock-on yield (#R ion-1) The knock-on yield of reactive gas atoms in the compound state. It is the yield of reactive atoms that are 

knocked of from a compound particle at the surface into the target subsurface by an incoming inert or reactive ion. 

Note that the used Bulk reaction rate values in RSD literature are conform with a zero Knock-on yield for the compound 

particle. If non-zero values are used, the Bulk reaction rate should probably be increased. 

 Chemisorbed particle MR_z 

o Sputter yield Y_c (#M ion-1) 

The sputter yield of chemisorbed particles MRz per incoming ion if the metal is chemisorbed by reactive atoms (chemisorbed state). This 
can optional be specified as a linear function of the discharge voltage. No distinction is made between an incoming inert or reactive ions. 

By definition the chemisorbed particles sputter congruently (=maintaining the existing stoichiometry) but are sputtered as atoms. 

No good estimates of sputter yields for chemisorbed particles are known, but are expected to lay between the metal and the compound 
sputter yield. 

o Secondary electron yield (#e ion-1) 

The ion-induced secondary electron emission yield for the chemisorbed state. If different from zero, the discharge current is considered to 
have an ion and an electron contribution. Otherwise discharge and ion current are assumed equal. 

No good estimates for the secondary electron yields of chemisorbed states are known, but should be typical lower than the metal state. 
o Effective sticking coefficient 

The effective sticking coefficient of non-sputtered reactive gas. It is the average probability for a gaseous reactive particle (atom or 
molecule) to chemisorb on a metallic surface to form a chemisorbed particle. 

No good estimates for the effective sticking coefficient on the target are known. Typically the same sticking coefficient as for the 
substrate may be used. 

o Knock-on yield (#R ion-1) The knock-on yield of reactive gas atoms in the chemisorbed state. It is the yield of reactive atoms that are 

knocked of from a chemisorbed particle at the surface into the target subsurface by an incoming inert or reactive ion. 

Knock-on yield may be estimated with Monte Carlo codes like SRIM www by defining a monolayer of oxygen on the metal and calculating 
the knock-on probability. 

http://www.srim.org/


 



 



Target window tab (part 2).  

Reactive atom R  

Not implemented yet. 

Reactive ion R2
+ [RSD only] 

 Sputter dilution by implanted ions 

If checked, the concentration of implanted reactive gas ions at the target surface will decrease the sputter yield of all (reacted) metal and all 
reactive atoms proportional with their relative concentration. 

Sputter dilution by implanted ions is only optional if the Time evolution method is chosen. 

Bear in mind that now ‘pure’ sputter yield for all particles (metal, compound and chemisorbed) are required as Monte Carlo codes like 
SRIM www ideally produce if this effect is not accounted for. 

o Reactive yield Y_r (#R ion-1) 

The sputter yield of non-reacted implanted reactive gas ions R per incoming ion. This can optional be specified as a linear function of the 
discharge voltage. No distinction is made between an incoming inert or reactive ions. 

Sputter yield of unbounded reactive gas in a metal can be estimated by Monte Carlo codes like SRIM www by defining a target with an 
equal metal as reactive gas density and setting the reactive gas surface binding energy zero. 

 Implantation profile 

Reactive ions get direct or knock-on implanted in the subsurface of the target according a specific spatial distribution. For both mechanisms, 
the same implantation profile is assumed. 

Implantation profiles and depth ranges can be estimated with Monte Carlo codes like SRIM www. 
o Gaussian 

A Gaussian or normal implantation distribution that is cut off at a depth of μ + 3σ.  

 Mean (nm) The mean μ of the Gaussian implantation profile. 

 Deviation (nm) The deviation σ of the Gaussian implantation profile. 

o uniform 

A uniform implantation distribution covering a specific Depth (nm). 

o uniform (fast) A uniform implantation distribution covering a specific Depth (nm), but less computational intensive as the analytical 

solution for the subsurface is used. 

uniform (fast) is only applicable if the Steady state method is chosen.  

http://www.srim.org/
http://www.srim.org/
http://www.srim.org/


 Depth (nm) 

The implantation range if a uniform or uniform (fast) implantation profile is chosen. 

 Saturation reactive gas 

A limitation on the reactive gas implantation in the subsurface of the target can be enforced if the subsurface reactive gas concentration 
exceeds a certain maximum. This maximum concentration is the sum of non-reacted and reacted reactive gas atoms in the subsurface. The 
possible overdose of implanted reactive gas atoms is then assumed to directly diffuse out of the target. The implantation limitation is 
established by a saturation function which takes the form of an error function. This saturation function scales the implantation dose based 
on the local reactive gas concentration. 

Estimates for the saturation concentrations of the reactive gas are hard. Feel free to use it as your favorite fit parameter. 
o non 

No saturation function is applied. All implanted reactive gas reside in the target subsurface. 
o abrupt 

A sharp limitation on the reactive gas implantation applies as the saturation/error function is centered around the limiting concentration L*z 
reactive atoms per metal atom with a ‘spread’ of zero.  

 Saturation limit L in MR_(L*z) 

The limitation L as L*z of reactive gas atoms per metal atom. 
o smooth 

A smooth limitation on the reactive gas implantation applies as the saturation/error function is centered around the limiting concentration L*z 
reactive atoms per metal atom with a ‘spread’ S*z.  

 Saturation spread S from MR_(L-S)*z to MR_(L+S)*z 

The smoothness S as S*z of reactive gas atoms per metal atom. 

 Atomic sticking coefficient 

If non-zero, out-diffusing and/or surface reaching implanted reactive gas atoms may chemisorb on non-reacted metal atoms at the target 
surface with the specified probability. 

Gas atoms are highly reactive, while gas molecules are less reactive. This sticking coefficient represent both species and should be 
estimated depending on the assumed ratio of both types. 



 



 



Target window tab (part 3).  

Geometry 

 Area (cm2) 

The surface area of the sputtered target. For a One-cell target, this corresponds with the effective eroded surface area (racetrack). For a 

Multi-cell target, this corresponds with the surface area where for a Current profile is specified below. 

 One-cell 

The One-cell description considers the target spatial 1-dimensional. It is spatial uniform in the lateral (x/r-y/θ) directions but spatial 

resolved in the longitudinal (z) direction. The ion current density on the target surface is uniform as well as the state of the target in the 
lateral directions. 

 Multi-cell 

The Multi-cell description considers the target spatial 3-dimensional. It is spatial resolved in both the lateral (x/r-y/θ) directions as in the 

longitudinal (z) direction. Specification of a Current profile is obligatory.  

o Shape 

Two geometrical shapes of the target are selectable, each with their own lateral spatial partitioning in target cells.  
 circular 

A planar circular target surface with a radius conform the specified Area.  

 
Spatial partitioning circular target.  

 rectangular\rotatable 

A planar rectangular\cylindrical target surface partitioned in x cells along its width\circumference) and in y cells along its length. All target 

cells are equal in surface area. 



 

 
Spatial partitioning rectangular target.  

o Rotation speed (rpm) 

If non-zero, the rotatable target is assumed to be a rotating cylindrical target surface with a rotation speed in rounds per minute in the x 

dimension. This option is only applicable for a rotatable target. 

o Number of grid cells  

 r or x 

For a circular target, the number of target cells in the radial r dimension. 

For a rectangular target, the number of target cells in the x dimension. 

 θ or y 

For a circular target, the number of target cells in the azimuthal θ dimension. 

As the Current profile for a circular target has to be axial symmetric, partitioning in the azimuthal dimension (θ > 1) is only 

useful if an asymmetric Redeposition profile is included. 

For a rectangular target, the number of target cells in the y dimension. 

 Equal area 

If checked, the circular target is partitioned in the radial dimension such that the target cells have all an equal surface area. Only applies 

for a circular target as the rectangular target is always equally partitioned. 

o Current profile 

The relative distribution of the ion current across the target surface has to be specified by an additional input file, the current profile file, 

which has to be conform with the chosen Shape of the target. Only applies for a Multi-cell description of the target.  

 Load file 

Browse for an appropriate current profile file or directly enter its path in the adjacent text field. 

 Redeposition [RSD only] 

If checked, redeposition of sputtered material back on the target shall be included.  



o Uniform redeposition 

A spatial uniform redeposition on the target is considered.  
 Fraction of sputtered flux 

The fraction (between 0 and 1) of the total sputtered flux that is redeposited on the target. The same fraction is used for both the sputtered 
metal as the sputtered reactive atoms. Editing this fraction changes in a conform way the total fraction of the sputtered flux deposited on all 

substrates, presented in Substrate> Geometry> Uniform deposition> Fraction of sputtered flux or Substrate> Geometry> 

Deposition profile> Only profile with fraction. 

o Redeposition profile 

A spatial resolved redeposition profile is considered, typically based on SiMTra simulations.  
 Manual input 

Old style manner of including the redeposition distribution on the target based on a SiMTra deposition profile file. This way of including 
redeposition does not need the SiMTra input file, only the deposition profile file and the spatial area it covers.  

 Input file listing the deposition files: 

An additional input file, the redeposition listing file, lists the single SiMTra deposition profile file that contains the redeposition distribution 

over the target besides the corresponding surface area. This file can be saved on the Standard file location or can freely be chosen 

by unchecking the box and editing the adjacent text field or using the Choose button. An already existing redeposition listing file can also be 

loaded in the same way. 
 Load redeposition file 

The location of the SiMTra deposition profile file containing the redeposition distribution can be looked up or the file location can directly be 
given in the text field. 

 Collecting area 

Each SiMTra deposition profile file defines a rectangular grid overlaying the considered surface. The area of this grid has to be provided and 
not the effective area of the considered surface. 

 SiMTra configuration 

This is the preferred way of including a redeposition distribution on the target. It is based on a SiMTra input file which should be specified in 

the text field under Target> Metal particle M> SiMTra. 

For the target, a single Object and Surface are listed. Non-editable properties of this Object and Surface are shown which can only be 

modified in the SiMTra GUI or the SiMTra input file.  
 Object 

The name of the object as defined in the SiMTra input file where the target surface is part of. The non-editable properties Position and 

Orientation of this object are listed. 

The symbol in front of the object name indicates if deposition profiles where saved during the SiMTra simulation and are as such included or 
not. 
■ : all contained surfaces of this object have deposition profiles 
□ : all contained surfaces of this object have NO deposition profiles 
◪ : some of the contained surfaces of this object have deposition profiles 



 Surface 

The name of the target surface as defined in the SiMTra input file. The symbol in front of the surface name indicates if the deposition profile 
was saved during the SiMTra simulation and is as such included or not. 
■ : surface has deposition profile 
□ : surface has NO deposition profile 

The non-editable properties Type, Position and Orientation within the local coordinate system, Area and Grid resolution are 

listed. Target rotation can only be specified under Target> Geometry> Multi-cell> Rotation speed if the Shape is a rotatable 

target. 
 Only fraction (uniform profile) 

If checked, only the redeposition fraction as simulated by SiMTra is used and a uniform redeposition is considered. 
 Only profile with fraction 

If checked, only the relative redepositoin profile as simulated by SiMTra are used and scaled by the given redeposition fraction. Editing this 

fraction changes in a conform way the total deposition fraction on all the substrates, presented in Substrate> Geometry> Uniform 

deposition> Fraction of sputtered flux or Substrate> Geometry> Deposition profile> Only profile with fraction. 

Substrate 

The window tab Substrate specifies the properties connected with the substrate surface and the interaction mechanisms of the reactive 

molecular gas with the deposited material. It specifies the deposition profile and fraction on the substrates. 



 



Substrate window tab.  

Compound formation 

 Effective sticking coefficient 

The effective sticking coefficient of non-sputtered reactive gas . It is the average probability for a gaseous reactive particle (atom or 
molecule) to chemisorb on a metallic surface to form a chemisorbed particle. 

Effective sticking (or incorporation) coefficient can be estimated based on the electronegativity difference between the metal and the 
reactive gas atom in combination by the rough relation found by Leroy et al. www 

Geometry 

 Area (cm2) 

The total surface area of all effective deposited substrates. Only applies if a Uniform deposition is chosen below. 

 Uniform redeposition 

A spatial uniform deposition on all the substrates is considered. 
o Fraction of sputtered flux 

The fraction (between 0 and 1) of the total sputtered flux that is deposited on the considered substrate surfaces. The same fraction is used 
for both the sputtered metal as the sputtered reactive atoms. Editing this fraction changes in a conform way the redeposition fraction on the 

target, presented in Target> Geometry> Redeposition> Uniform redeposition> Fraction of sputtered flux or Target> 

Geometry> Redeposition> Redeposition profile> Only profile with fraction. 

 Deposition profile 

A spatial resolved deposition profile is considered, typically based on SiMTra simulations.  
o Manual input 

Old style manner of including the redeposition distribution on the substrate based on a SiMTra deposition profile files. This way of including 
redeposition does not need the SiMTra input file, only the deposition profile files and the spatial areas they cover.  

 Input file listing the deposition files: 

An additional input file, the deposition listing file, lists all the SiMTra deposition profile files that contain the deposition distributions over the 

considered substrates besides their corresponding surface area. This file can be saved on the Standard file location or can freely be 

chosen by unchecking the box and editing the adjacent text field or using the Choose button. An already existing deposition listing file can 

also be loaded in the same way. 
 Load deposition files 

The locations of the SiMTra deposition profile files containing the deposition distributions can be looked up or the file locations can directly 
be given in line by line in the text field. 

https://doi.org/10.1016/j.tsf.2009.07.190


 Collecting area 

Each SiMTra deposition profile file defines a rectangular grid overlaying the considered surface. The area of this grid has to be provided and 
not the effective area of the considered surface. 

 Skip counts equal zero 

Checking will exclude substrate cells in the overlaying grids that have a zero deposition fraction. These substrate cells are considered not 
real and will be assigned a -1 value in the RSD spatial resolved output files. This option is useful for example for a circular substrate surface 
which is covered by a rectangular grid. This results in unreal substrate cell in the grid corners. 

 Include rotation 

Checking will need specification of Rotation speed for all the substrates listed. Only circular substrate surfaces are allowed to rotate 

here, other surfaces need a zero value. 
o SiMTra configuration 

This is the preferred way of including deposition distributions for the substrates. It is based on a SiMTra input file which should be specified 

in the text field under Target> Metal particle M> SiMTra. 

For the Substrate, Object list the SiMTra defined objects and Surface lists the composing surfaces of each Object. Non-editable 

properties of the Object and Surface are shown which can only be modified in the SiMTra GUI or the SiMTra input file  

 Object 

The name of the object as defined in the SiMTra input file where the target surface is part of. The non-editable properties Position and 

Orientation of this object are listed. The symbol in front of the object name indicates if deposition profiles where saved during the SiMTra 

simulation and are included or not. 
■ : all contained surfaces of this object have deposition profiles 
□ : all contained surfaces of this object have NO deposition profiles 
◪ : some of the contained surfaces of this object have deposition profiles 

 Surface 

The name of the surface as defined in the SiMTra input file for the selected The symbol in front of the surface name indicates if the 
deposition profile was saved during the SiMTra simulation and are included or not. 
■ : surface has deposition profile 
□ : surface has NO deposition profile 

The non-editable properties Type, Position and Orientation within the local coordinate system, Area and Grid resolution are 

listed. 

Axial Rotation can be specified if the surface Type is a circle. Only a single SiMTra simulation is needed then. In the other case, it will 

not be visible or it states that it is SiMTra specified when SiMTra>Use SiMTra deposition simulations>Enable movement is 

selected and the possible movement of the surface will be accounted by SiMTra. 
o Only fraction (uniform profile) 

If checked, only the deposition fraction as simulated by SiMTra is used and a uniform deposition is considered. 
o Only profile with fraction 

If checked, only the relative depositoin profiles as simulated by SiMTra are used and scaled by the given deposition fraction. Editing this 

fraction changes in a conform way the redeposition fraction on the target, presented in Target> Geometry> Redeposition> Uniform 



redeposition> Fraction of sputtered flux or Target> Geometry> Redeposition> Redeposition profile> Only profile 

with fraction. 

Output 

The window tab Output specifies which simulation results should be printed to a file, at which frequency and where to save these files. 



 



Output window tab.  

Location 

 Select the output directory 

The directory where all RSD output files will be saved. The directory can be selected by Choose or by editing the text field. If the directory 

does not exist, the directory will be created. When a new RSD simulation is saved from an existing listed RSD simulation by using Save as 

..., a new output directory is automaticly created with as name the name of the newly saved RSD main input file. 

 Prefix for output files: 

In the text field a string prefix has to be specified which will be pre-appended to each RSD output file. When a new RSD simulation is saved 

by Save as ..., the prefix will automaticly assigned the name of the newly saved RSD main input file. Checking Simulation>Auto 

prefix will automaticly attribute a number to the prefix field and gray out this field for all simulations listed in the simulation list window. 

Results 

By checking the boxes, desired simulation output can be selected to be printed out in files. The available outputs, those that are not grayed 

out, depend on previous choices and selected options. For example, when choosing the One-cell in the Target tab and Uniform 

deposition in the Substrate tab, only the Spatial averaged check box can be chosen. 

Two output formats can be chosen for the Spatial resolved data: ASCII or binary. The binary format is much compacter compared 

to the regular ASCII format. The structure of the numerical data is nevertheless the same, only will every numerical be represented by a 32 

bit IEEE float value. 

 Spatial averaged 

Checked will always create an output file with the suffix hyst_steady.out. This output file contains the simulated system variables under 

steady state conditions. If the Time evolution method is chosen an additional output file with the suffix hyst_time.out is created. This 

output file contains the simulated system variables as a function of time. The used time interval for printing out results can be specified by a 

multiple of the intergration Time step. If this multiple is set 0 than only at the end of every simulation step (= a specific set of operation 

conditions), the results will be printed out. Additional info about these two output files can be found in the section Spatial averaged. 

 Spatial resolved 

Checking this box will only be possible when Multi-cell for the Target and/or the Deposition profile for the Substrate is chosen. 

In this case the check boxes under Target and Substrate will become available. The used time interval for printing out results can be 

specified by a multiple of the intergration Time step. If this multiple is set 0 than only at the end of every simulation step (= a specific set of 

operation conditions), the results will be printed out. 
o Target  

 Subsurface profile [RSD only] 

Spatial 1-dimensional data if a One-cell target is chosen. Spatial 2 or 3-dimensional data if a Multi-cell target is chosen.  



 Non reacted metal fraction 

The relative metal concentration nM/n0 in the target subsurface that is not chemical reacted with the implanted reactive gas atoms. 

The relative reacted metal concentration is simply the complement 1-nM/n0. 
 Unbounded reactive fraction 

The relative reactive gas concentration nR/n0 in the target subsurface that is not bounded to the metal atoms. 
 Surface profile 

Spatial 2-dimensional data which is available if a Multi-cell target is chosen.  

 Metal fraction 

The metal M atom fraction θm at the target surface where no reactive gas atoms are bounded on. 

 Compound fraction [RSD only] 

The atom MRz fraction θr at the target surface where z reactive gas atoms are chemical bounded on. 
 Chemisorbed fraction 

The atom MRz fraction θc at the target surface where z reactive gas atoms are chemisorbed on. 

 Surface speed (cm s-1) 

The effective speed vs of the target surface. 

 Erosion speed (cm s-1) 

The erosion speed ve of the target surface if no redeposition is considered. 

 Erosion depth (cm) 

The deepening of the target by the effective surface speed. Only applicalbe if the Time evolution method is chosen. 

 Reactive flow (sccm) 

The reactive molecular gas flow Qt) gettered by the target. 

 Ion current (A) 

The ion current Iion that flows through the target surface. 

 Area (cm2) 

The area At of the target surface. 

 Redeposition fraction (cm-2) [RSD only] 

The redeposition fraction εt per unit of area on the target. 
o Substrate 

 Surface profile 

Spatial 2-dimensional data which is available if a Deposition profile for the Substrate is chosen.  

 Compound fraction 

The atom MRz fraction θs at the substrate surface where z reactive gas atoms are chemical bounded on. 

 Reactive flow (sccm) 

The reactive molecular gas flows Qs) gettered by the substrate cells. 

 Area (cm2) 

The surface areas At of the substrate cells. 



 Deposition fraction (cm-2) 

The deposition fractions εs per unit of area on the substrate cells. 
o Input file with the results specifications 

The selection of which results are printed out to files and in which format are saved in an additional input file, the result specification file. 

This file can be saved on the Standard file location or can freely be chosen by unchecking the box and editing the adjacent text field 

or using the Choose button. An already existing result specification file can also be loaded in the same way. 

Simulation list 

The simulation list window lists the loaded or created simulation inputs. A simulation in the list is represented by the file name of the main 
input file connected to a simulation. By clicking on an item in the list, the simulation input is loaded into the window tabs for editing. 

The simulation input which is current in scope is blue highlighted in the simulation list window. Selecting another simulation in the list will 
automaticly save the made changes in the previous simulation input. 

Multiple simulations in the list can be selected (=blue highlighted) to perform one of the following actions: 

 Delete 

Key stroke that removes the selected simulations from the list. 

The input files are NOT removed from your disk, only from the simulation list window. 

 Simulation>Run selected  

Sequentially run the selected simulations. 

Right-clicking with the mouse on a selected (=blue highlighted) item in the simulation window list shows the following actions: 

 Scan 

Allows to automaticly generate a series of simulations where one or more parameters is varied over a predefined range. 



 

 
Scan window, one varied parameter.  



 

 
Scan window, two varied parameter.  

Scan 

The Scan action allows to do a multiple parameter scan. This action is executed on a selected simulation input from the simulation list 

window. Most parameters of the simulation input can then be varied. For each parameter combination, a new main input file will be 
generated and as such be inserted as a new item in the simulation list window. 

Selecting this Scan action for an item in the window list pops up the scan window. Two lists are defined: 

 Fixed parameters 

It lists the parameters that can been chosen to do a parameter scan for. 

 Varied parameters 

Initial an empty list where items of the Fixed parameters list can be placed in by the right arrow and put back by the left arrow. Selecting 

an item in the Varied parameters list let you define a value range over which this parameter should be varied at the bottom of the 

window.  
o Start value 

Start value (lower limit) of the selected parameter in the Varied parameters list. 



o End value 

End value (upper limit) of the selected parameter in the Varied parameters list. 

o Number of steps 

Number of parameter values that will be accessed for the selected parameter in Varied parameters defined by Start value and End 

value, including (at least) these lower and upper limit. 

o Total steps 

Total number of simulations created based on all the parameter variations. Non-editable field. 
o Logarithmic stepping 

Checking will logarithmicly spread the values for a selected parameter over its range where the default is linearly. 

Pressing Ok will generate the simulation inputs and add them to the simulation list window. The file names of the main input file of each item 

is automatically assigned. The filename of the original main input file is concatenated with the string scan, a keyword characteristic for the 

varied parameter and the value of the scanned parameter. 

The generated main input files will NOT have an own copy of the referenced additional input files. 



 



 



Simulation list window with one varied parameter.  



 



 



Simulation list window with two varied parameter.  

Command line 
The RSD2013 simulation software can be used without the GUI. The executable RSD2013.exe can directly be executed on the Command 

Prompt if it is provided with the absolute path of a main input file or its relative path with respect to the program directory (where the 

RSD2013.exe executable is located). This is useful if you want to run the RSD2013 simulation in a script. 

This main input file and the additional input files where it references to, can manually be edited or be created by the GUI. 

Input files 

The input files define all the input needed for a successful RSD2013 simulation. Two types of input files are distinguished: 

 A main input file which contains input parameters, simulation options and path references to the additional input files. 
 The additional input files define more specific input data and options for a simulation or further path references to additional input files. 

Some input files are allowed to start or contain comment lines. Those file usually begin with an explanation of the structure of that input file. 

A comment line always starts with #. 

Main input file 

The main input file is the input file which is provided to the simulation executable RSD2013.exe. It contains all data and references to data 

needed for running the simulation. It is a text based file. 



 

 



Comment section of main input file.  



 

 



Input section of main input file.  

The structure of the file is as follows. It starts with a comment section where every line starting with # is considered as a comment line and 

is ignored. After this comment section, each line defines input and starts with the keyword rowXXX, where XXX is a number. This keyword 

rowXXX is omitted when reading in the file. Nevertheless, the line number of each text line defines which kind of parameter, option or 

reference should be defined. Explanation of which kind of information is expected on each line is given in the comment lines starting this file. 

 
Almost no input restrictions apply in the GUI, and no validity check at the start of a simulation run is performed. Give valid input values are 
up to the responsibility of the user. 

Additional input files 

The additional input files are all other input files than the main input file. The main input file contains references to these additional input 
files, but these additional input files can also contain further references to other additional input files. Several types of additional input files 
the RSD2013 software possibly needs and/or creates are given below. 

Step file 

The step file can be created or modified under Method> Solution method> Time evolution method> Step file. 



 

 
Step file.  

The step file defines the evolution of the Varied operation parameter(s) for the Time evolution method. This input file can be 

edited or loaded in the window tab Method>Stepfile when choosing the Time evolution method. The step file is a text based file 

which consist out of numerical text lines. After an optional comment section (lines starting with #), the pulsing of the Varied operation 

parameter(s) can be specified as no pulsing NA or block pulsing block. The second non-comment line should contain the number of 

value ranges (or numerical text lines) that are specified next. Each consecutive line defines then a range over which the Varied 

operation parameter(s) may be varied. The first entry of such a line defines the start value, the second entry the end value, the third 

entry the step with which the start value is stepwise increased until it reaches the end value. The last entry is the maximum time the given 
`Varied operation parameter(s)` may be set, depending on the chosen options for the parameter stepping. 



Current profile file 

The current profile file can be loaded under Target> Geometry> Multi-cell> Current profile. 

The current profile file defines how the total ion current is distributed over the target. Two types of current profile are possible depending on 

the shape of the target: a circular or a rectangular target. The current profile file is a text based file. The first non-comment line is the 

keyword circular or rectangular that can be enclosed by comment lines. The numerical text lines define the profile. The profile has not 

be particularly normalized. 

 circular 

An axial symmetric profile is assumed where as such only an 1-dimensional radial profile has to be specified. The first entry of each line is 
the radial distance, the second entry is the value of the profile at that position. Only the relative radial distance is importants as the profile 

will be scaled on the target Area. 

 



 
Circular current profile file.  

 rectangular 

A 2-dimensional rectangular profile has to be specified as a matrix. The number of columns corresponds with the partitioning of the target in 

the y dimension while the number of rows with the partitioning in the x dimension. Each matrix elements represents the relative ion current 

to the target cell.  



 
Rectangular current profile file.  

SiMTra input file 

The SiMTra input file can be loaded and modified under Target>Metal particle M> SiMTra. 

The SiMTra input file should be a valid input file for the SiMTra version 2.2 For details about this file, check the SiMTra documentation. 

(Re)deposition listing file 



The (re)deposition listing file can be loaded and/or assigned under Target> Geometry> Redeposition> Manual input> Input file 

listing the deposition files for the target and under Substrate> Geometry](#SubstrateGeometry)> Deposition profile> 

Manual input> Input file listing the deposition files for the substrates. 

 

 
Redeposition listing file.  



 

 



Deposition listing file.  

Only needed if the old style of including deposition distributions is used (Manual input). The preferred way is the loading a SiMTra 

input file. 
The file lists the deposition profile files for the target (only one) or for the substrate (multiple possible). Its structure is as follows: the first 
non-comment line of the file gives the number of included (re)deposition profile files. Each following couple of lines represent the full path or 
relative path of the deposition profile file, while the second line contains the area which corresponds with the deposition profile. This area 

should take into account the full rectangular matrix of the profile, also when there are (ignored) zero elements (Skip counts equal 

zero). 

(Re)deposition profile file 

A single redeposition profile file can be loaded under Target> Geometry> Redeposition> Manual input> Load deposition files 

for the target and multiple deposition files can be loaded under Substrate> Geometry> Deposition profile> Manual input> Load 

deposition files for the substrates. 

Only needed to be specified if the old style of including deposition distributions is used (Manual input). The preferred way is the 

loading a SiMTra input file 



 

 
Deposition file.  

A (re)deposition profile file defines the relative number of sputtered particles (atoms) that is deposited on a surface. Such file is text based 
and matrix structured conform a deposition file from SiIMTra. The first two entries on the first line define respectively the number of rows 
and columns of the matrix. The rest of the line is ignored. All following lines define the matrix with integers. 

Result specification file 

The result specification file can be specified or loaded under Output> Results> Input file with the results specifications. 

The file with the results specifications determines which output will be generated when a simulation is executed. The text file structure 

closely resemblance the window tab Output. 

With each kind of output, a keyword is linked. When this keyword is not preceded by x, o or v, this output is not printed to file. The x is 

used for a checkbox, the o for a radiobutton and v for a choice in a roll-down list. 



 



 



Result specification file.  

In this example the spatial averaged variables are generated, the spatial resolved metal fractions on the target are generated in an ASCII 
format and in binary format the spatial resolved compound fractions on the substrate are generated. 

The frequency of printing out results as a multiple of the Time step, is saved in the main input file. 

Output files 
Output files always have the extension .out. Which output files are produced, is determined by the result specification file or in the window 

tab Output. A summary of the simulation run is always generated and is recognized by the ending string summary.out. The file name of 

each other output file starts with the chosen Prefix for output files and ends with an unique keyword string. 

Spatial averaged 

Two output files may correspond with the Spatial averaged option. For the Steady state method, only an output file with suffix 

hyst_steady.out is produced. Each column in this file states the following steady state variables 

1. Q_r : flow of reactive gas introduced in the vacuum chamber 
2. p_r : partial pressure of reactive gas 
3. theta_s : spatial averaged compound fraction on substrate surface 
4. theta_m : spatial averaged metal fraction on target surface 
5. theta_c : spatial averaged chemisorbed fraction on target surface 
6. theta_r : spatial averaged compound fraction on target surface 
7. theta_m,ss : spatial averaged metal fraction at the target surface/subsurface interface 
8. n_R/n0 : relative concentration of non-reacted implanted reactive gas atoms at the target surface/subsurface interface 
9. Q_p : reactive gas flow pumped away by the vacuum pump 
10. Q_s : reactive gas flow consumed by compound formation on the substrate 
11. Q_t : reactive gas flow consumed (> 0) or released (< 0) by the target 
12. V : discharge voltage 
13. I : discharge current 
14. I_ion : ion current to the target 
15. S : pumping speed of the vacuum pump 



 

 
Output file hyst_time.out.  

For the Time evolution method, this file contains the values of the variables at the end of every Varied operation parameter(s) 

step. A second output file is also generated with suffix hyst_time.out. This file contains the same variables as above, but adds as 12th 

column the time elapsed in the simulation. 
1. t : time in the simulation 



The spatial averaged variables correspond with these time stamps where the frequency is specified as a multiple of the Time step. 

The spatial averaged values are in fact weighted by the Current profile. 

Spatial resolved 

When the target and/or the substrate is spatial resolved by defining respectively a Current profile and/or a Deposition profile, 

spatial resolved output can be generated. We consider spatial resolved output on a surface (2D) for the target and the substrate or within a 
volume (3D) for the target. The format how this data is written to the files can be simple ASCII or in a binary format. In the binary format the 
structure is the same as for the ASCII format, but every number is binary represented by a 32 bit IEEE float value. 

Surface profile (2-D) 

Surface resolved output can be generated for the target and for the substrate when choosing a Current profile and a Deposition 

profile respectively. A table listing the different variables which can be resolved on a surface is given under Output> Results. 

The format of the file is as follows. The first entry of the first line of the file is the number of columns which equals the cells in the x or radial 

dimension. The rest of the first line numbers the columns starting from zero. The first entry on each following line numbers the rows which 

equals the cells in the y or azimuthal dimension. The following entries on each line represent the variable value in the matrix. 

If a substrate surface (only a Circle) is specified to axial rotate at a given speed within RSD, not if Enable movement is selected, the 

output matrix is a polar representation of the surface with the rows as the radial and the columns as azimuthal dimension. 

The data of the surface is saved at every steady state point if 0 is specified for Spatial resolved or at the specified multiples of the Time 

step The row numbering is restarted after every print out. A value of -1 means that this surface cell is not considered in the simulation. 

For the Spatial resolved substrate: 

- Substrate> Geometry> Deposition profile> Manual input : 

The output file names are suffixed with the order number as they occur in the deposition listing file. 

- Substrate> Geometry> Deposition profile> SiMTra configuration : 

The same directory structure as the SiMTra output for the different Object and Surface is constructed with the Object name and 

Surface name appended to the file names. 

Subsurface profile (3-D) 

Subsurface resolved output can be generated for the target when choosing a current profile. A table listing the different variables which can 

be resolved for the subsurface is given under Results. 

The format of the file is as follows. The first entry of the first line is 100, the number of columns which equals the in-depth points where a 
fraction is defined. The rest of the first line defines the depth (in cm) where a variable is resolved. This depth stretches over the implantation 

CurrentProfile


zone (which equals μ + 3σ for a Gaussian profile or the Depth for a uniform profile). The first entry on each following line numbers the rows 

which equals the number of surface cells (product of the number of cells in the y or azimuthal dimension and of the number of cell in the x 

or radial dimension). The numbering starts with the number of cells in the y or azimuthal dimension for a fixed x or radial cell. The following 

entries on each line represent the in-depth values for the corresponding surface cell. 

The data of the surface is saved at every steady state point if 0 is specified for Spatial resolved or at the specified multiples of the Time 

step The row numbering is restarted after every print out. A value of -1 means that this surface cell is not considered in the simulation. 

End remark 

I would be grateful for any comment, suggestion for improvement, mistake or typo occurring in this documentation or software. Feel 
encouraged to contact us at koen.strijckmans@ugent.be (or diederik.depla@ugent.be). 
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